Should I use `!IsGood` or `IsGood == false`?

Posted by chills42 on Stack Overflow See other posts from Stack Overflow or by chills42
Published on 2008-12-10T14:23:51Z Indexed on 2010/03/25 23:13 UTC
Read the original article Hit count: 375

I keep seeing code that does checks like this

if (IsGood == false)
{
   DoSomething();
}

or this

if (IsGood == true)
{
   DoSomething();
}

I hate this syntax, and always use the following syntax.

if (IsGood)
{
   DoSomething();
}

or

if (!IsGood)
{
   DoSomething();
}

Is there any reason to use '== true' or '== false'?

Is it a readability thing? Do people just not understand Boolean variables?

Also, is there any performance difference between the two?

© Stack Overflow or respective owner

Related posts about not-operator

Related posts about boolean